🔧 Scheduled Maintenance 🔧Today 26 March 2025

Incident Report for SalesQL

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 21:27 UTC

Identified

📅 Date: Today 26 March 2025
⏰ Start Time: 21:00 CET (Central European Time)
⏳ Estimated Duration: Approximately 3 hours

🚨 Impact: During this time, the SalesQL extension, dashboard, and login will be temporarily unavailable.

👨‍💻 Reason: This update is essential to improve system stability

We appreciate your patience while we work on optimising our service. We’ll keep you updated and let you know as soon as everything is back to normal.

Thanks for your understanding! 💙
Posted Mar 26, 2025 - 19:47 UTC
This incident affected: Web Application, Browser Extension, and Public API.