🚨 Incident Report – Service Disruption

Incident Report for SalesQL

Resolved

Resolved: API, Prospector, and CSV issues are now fixed.

Ongoing: Some users may still experience problems with extension automations. Our team is actively working on a fix.

Workaround: In the meantime, you can use the Bulk function to continue enriching contacts: https://help.salesql.com/en/articles/8727329-bulk-enrichment-over-linkedin


We appreciate your patience.
Posted Aug 20, 2025 - 14:04 UTC

Investigating

Identified: Our team has detected a service disruption affecting several core features.

Impact: Users may experience failures when calling the API, running searches in Prospector, exporting/importing CSV files, or using automation via the Chrome extension.

Status: The issue started approximately 1 hour ago. Our engineering team is actively investigating and working on a fix.
Posted Aug 20, 2025 - 13:42 UTC
This incident affected: Browser Extension and Public API.